SYSPRO Hotfixes
Exploring
 Where it fits in?
Where it fits in?
                                                                        A hotfix is the minimum software required to provide a solution for a specific problem experienced by one or more customers. These can also include any relevant dependencies.
SYSPRO provides hotfixes as a way of deploying software updates during the release of SYSPRO 8.
Types of hotfixes available include:
- 
                                                                                    Mandatory Hotfix 
- 
                                                                                    Optional/Customer-specific Hotfix 
- 
                                                                                    Consolidated Hotfix 
- 
                                                                                    Diagnostic Hotfix 
- 
                                                                                    Restricted Hotfix 
- 
                                                                                    Withdrawn Hotfix 
Hotfixes are available from the SYSPRO Installer application.
 Types of Hotfixes
Types of Hotfixes
                                                                         Mandatory Hotfix
Mandatory Hotfix
                                                                                Occasionally, a Mandatory Hotfix is made available. This could be because of one of the following:
- A serious error that we believe most customers will want corrected.
- An architectural change to improve areas such as: security, performance, scalability, reliability, or the introduction of new foundation for several other hotfixes.
Who is notified?
Anyone who is using the current release of the software. Notification is via email.
Who can install the hotfix?
All customers who are using the current release of the software and have not yet installed the mandatory hotfix.
Can the hotfix be uninstalled?
No, you cannot uninstall a mandatory hotfix.
 Optional/Customer-specific Hotfix
Optional/Customer-specific Hotfix
                                                                                Most hotfixes are optional. An Optional/Customer-specific Hotfix is targeted at a specific customer who has reported a bug and a specific hotfix exists to resolve the issue.
Other customers can also elect to install an Optional/Customer-specific Hotfix if they believe that the issue is relevant to them.
Who is notified?
The customer who reported the bug is notified when the Optional/Customer-specific Hotfix to resolve this is available. Notification is via email.
Who can install the hotfix?
The customer who raised the bug is notified about the hotfix availability. However, all customers may use the SYSPRO Installer app to select and install the hotfix, if deemed relevant.
Can the hotfix be uninstalled?
Yes, if required you can uninstall an Optional/Customer-specific Hotfix
 Consolidated Hotfix
Consolidated Hotfix
                                                                                Occasionally, the development team may produce a Consolidated Hotfix that contains a roll-up of all prior hotfixes.
The descriptive synopsis will explain the hotfixes that have been included and summarize how this roll-up and install works.
Please refer to the SYSPRO 8 Consolidated Hotfixes technical guide for more information.
Who is notified?
No notifications are sent out, however anyone using the current release of the software can view any available Consolidated Hotfix from the SYSPRO Installer application.
Who can install the hotfix?
Anyone using the current release of the software can install a Consolidated Hotfix.
Can the hotfix be uninstalled?
Yes, if required you can uninstall a Consolidated Hotfix. The software will then revert to just the previously installed hotfixes.
 Diagnostic Hotfix
Diagnostic Hotfix
                                                                                Occasionally, the development team may produce a Diagnostic Hotfix. These are aimed at specific customers to provide additional diagnostic output and/or other diagnostic features.
A Diagnostic Hotfix is only intended to be used for a limited period of time (while diagnosing any problems) and is typically uninstalled once the diagnostic phase has completed. Often this is followed by an Optional/Customer-specific Hotfix/Mandatory Hotfix to resolve the identified issue(s).
Who is notified?
No notifications are sent as the development and/or support team will contact the customer directly.
Who can install the hotfix?
Only the customer who has a problem requiring a Diagnostic Hotfix.
Can the hotfix be uninstalled?
Yes, upon completion of the diagnostic phase, the hotfix should be uninstalled.
 Restricted Hotfix
Restricted Hotfix
                                                                                Occasionally, the development team may issue a Restricted Hotfix that only a specific customer can install.
This could be of a very customer-specific nature, or may be a high-risk change where close customer support is required during hotfix implementation.
Who is notified?
The specific customer is notified. Notification is via email.
Who can install the hotfix?
Only the specific customer who requires the Restricted Hotfix.
Can the hotfix be uninstalled?
Yes, if required, you can uninstall a Restricted Hotfix.
 Withdrawn Hotfix
Withdrawn Hotfix
                                                                                Occasionally, a published hotfix may contain an error, in which case the hotfix will be flagged as withdrawn.
Who is notified?
All customers who have previously installed the Withdrawn Hotfix.
Who can uninstall the hotfix?
Only customers who had installed the Withdrawn Hotfix.
Can the hotfix be uninstalled?
The hotfix must be uninstalled, regardless of whether there is a subsequent replacement hotfix.
If required, a replacement hotfix is published and the list of customers who were notified about the Withdrawn Hotfix are notified about the replacement hotfix.
 
                                                                        - 
                                                                                    Hotfixes are available from the SYSPRO Installer application. If there is a Mandatory Hotfix or Optional/Customer-specific Hotfix available for your customer code then once you login, a notification is displayed against the applicable deployment group. Selecting the HOTFIXES button displays a list of all available hotfixes. 
Starting
 Warnings
Warnings
                                                                        When installing hotfixes, the app will stop the following SYSPRO Services in order to prevent any possible problems arising:
- 
                                                                                    SYSPRO 8 e.net Communications Load Balancer This includes any additional SYSPRO 8 e.net Communications Load Balancer services installed. 
- SYSPRO 8 Communications Service
- SYSPRO 8 Avanti Initialization Service
Once the hotfixes are installed, the app will try to start the services again.
 Restrictions and Limits
Restrictions and Limits
                                                                        - 
                                                                                    Hotfixes are only displayed when running the SYSPRO Installer application on the server to which the SYSPRO 8 Server component has been installed. 
- 
                                                                                    A maximum of 127 hotfixes can be installed per release (Microsoft limitation). Therefore, ensure that you only install hotfixes that you require. Alternatively, install a consolidated hotfix. 
Solving
 Error messages
Error messages
                                                                         Hotfix Limit Exceeded
Hotfix Limit Exceeded
                                                                                 Synopsis
Synopsis
                                                                                        This error is displayed when your selection of hotfixes to install exceeds the Microsoft limit.
 Cause
Cause
                                                                                        A maximum of 127 hotfixes can be installed per release (Microsoft limitation).
 Solution
Solution
                                                                                        Either deselect hotfixes which you may not need, or alternatively select to install a consolidated hotfix which only counts as 1 hotfix but includes a roll-up of previously released hotfixes.
If you select to install a consolidated hotfix, the previously installed hotfixes are uninstalled and your number of hotfixes installed then decreases accordingly.
 FAQs
FAQs
                                                                         General
General
                                                                                 How do I search for Hotfixes
How do I search for Hotfixes
                                                                                        Within the Hotfix Selection screen of the SYSPRO Installer, you can search for a specific hotfix by any of the following:
- Enter the full KB number (e.g. KB8000006)
- Enter the last digits (e.g. 06) into the search box
- Enter any full text related to the hotfix (e.g. Ledger Query)
This will show Mandatory Hotfixes and Optional Hotfixes.
There could be a large number of hotfixes available - many of which are not relevant to your site or how you use the software. Therefore, only use this function if you have received an Optional/Customer-specific Hotfix to install, or if you suspect a problem with your current SYSPRO software and want to establish whether an applicable hotfix is available.
 What are Hotfix Knowledge Base Articles
What are Hotfix Knowledge Base Articles
                                                                                        A hotfix KB article contains information about the software included in the hotfix, as well as a summary of the problems addressed.
You can access these by selecting the More button against the hotfix on the Hotfix selection screen of the SYSPRO Installer application.
 Why is the HOTFIXES button displayed without any Mandatory or Optional Hotfixes?
Why is the HOTFIXES button displayed without any Mandatory or Optional Hotfixes?
                                                                                        If there is no Mandatory Hotfix/Optional/Customer-specific Hotfix available for your customer code, but the HOTFIXES button is still displayed on the deployment group home page, then the application has detected that there are additional Optional Hotfixes available for you to view and optionally select.
 Who can access the hotfix notification button on the SYSPRO Ribbon bar?
Who can access the hotfix notification button on the SYSPRO Ribbon bar?
                                                                                        Although the hotfix notification button is visible to all users, it is only enabled for operators belonging to a group with system administrator privileges.
 What does the hotfix notification button on the SYSPRO Ribbon bar do?
What does the hotfix notification button on the SYSPRO Ribbon bar do?
                                                                                        This button shows the Mandatory or Optional Hotfixes recorded against your customer code, which have not yet been installed.
 Installing hotfixes
Installing hotfixes
                                                                                 What happens when I have multiple application servers for one site and need to update software or deploy hotfixes?
What happens when I have multiple application servers for one site and need to update software or deploy hotfixes?
                                                                                        If you have multiple application servers for the same site, you have to run the SYSPRO Installer on each machine that has the Application Server installed. This is because hotfixes must be applied directly to the Application Server.
 How many hotfixes can be installed per release?
How many hotfixes can be installed per release?
                                                                                        A maximum of 127 hotfixes can be installed per release (Microsoft limitation). Therefore, ensure that you only install hotfixes that you require. Alternatively, install a consolidated hotfix.
 How can I identify a consolidated hotfix?
How can I identify a consolidated hotfix?
                                                                                        When using the SYSPRO Installer application, a consolidated hotfix is clearly indicated with the following phrase appended to its name: ** Consolidated **.
The synopsis will explain the hotfixes that have been included and summarizes how this roll-up and install works.
 Uninstalling hotfixes
Uninstalling hotfixes
                                                                                 Can I uninstall a hotfix?
Can I uninstall a hotfix?
                                                                                        Yes, in the unlikely event that a deployed hotfix contains a flaw that may result in more damage than it was trying to repair, you can uninstall the hotfix.
The system is able to revert affected programs to a state prior to the deployment of the faulty hotfix.
 What happens if I uninstall a Consolidated Hotfix?
What happens if I uninstall a Consolidated Hotfix?
                                                                                        One of the best things about the hotfix technology in SYSPRO 8 is that if, for any reason, you wish to uninstall a hotfix, the software is restored back to what it was prior to the hotfix being installed.
The same happens if you were to uninstall a consolidated hotfix. The software will revert to just the previously installed hotfixes.
Using
 Installing SYSPRO Hotfixes
Installing SYSPRO Hotfixes
                                                                        Ensure to run the SYSPRO Installer app on the SYSPRO application server before attempting to install hotfixes.
When installing hotfixes, the app will stop the following SYSPRO Services in order to prevent any possible problems arising:
- 
                                                                                        SYSPRO 8 e.net Communications Load Balancer This includes any additional SYSPRO 8 e.net Communications Load Balancer services installed. 
- SYSPRO 8 Communications Service
- SYSPRO 8 Avanti Initialization Service
Once the hotfixes are installed, the app will try to start the services again.
 1. Login
1. Login
                                                                                Once a connection is made to the SYSPRO Deployment Service, you need to login using your InfoZone credentials.
A valid InfoZone account is required to continue.
Enable the Save Customer Details checkbox option if you want the app to save your Customer Code and Customer PIN when logging in.
If you are not listed as a customer on the InfoZone (i.e. you are a Partner or Super-user) an additional screen is displayed for you to enter the relevant customer code for the customer you want to install.
Partners and Super-users
The Customer ID defaults to the customer code defined within your InfoZone profile, and must match the SYSPRO account you are installing.
The Customer PIN is the 6-digit code included in the email you received that contained your SYSPRO 8 license.
You can verify your customer ID and PIN against the CustomerId and CustomerPin elements of the license XML file.
 4. Hotfix Selection
4. Hotfix Selection
                                                                                From the Hotfix Selection screen you can select the hotfixes that you want to deploy.
Use the More button to view additional information on each hotfix before selecting it for installation.
Additional options available:
- 
                                                                                            Use the Show Consolidated Hotfixes button to filter the list to only display consolidated hotfixes. If there are no consolidated hotfixes available, then this button is not available. When selecting to filter on consolidated hotfixes, the Search box is disabled. If you wish to return to the complete hotfix list, simply select the Show All Hotfixes button. 
- 
                                                                                            Use the Show Installed Hotfixes button to view all hotfixes installed for the deployment group. 
Once you have indicated the hotfixes that you require deployed, select the Continue button.
 Uninstalling SYSPRO Hotfixes
Uninstalling SYSPRO Hotfixes
                                                                        When uninstalling hotfixes, you can either do this through the SYSPRO Installer application, or Windows.
If you uninstall a Consolidated Hotfix, ensure that you immediately install any outstanding Mandatory Hotfixes to avoid possible problems in SYSPRO.
 Uninstalling hotfixes through the app
Uninstalling hotfixes through the app
                                                                                Ensure to run the SYSPRO Installer app on the SYSPRO application server before attempting to uninstall a hotfix.
 1. Login
1. Login
                                                                                        Once a connection is made to the SYSPRO Deployment Service, you need to login using your InfoZone credentials.
A valid InfoZone account is required to continue.
Enable the Save Customer Details checkbox option if you want the app to save your Customer Code and Customer PIN when logging in.
If you are not listed as a customer on the InfoZone (i.e. you are a Partner or Super-user) an additional screen is displayed for you to enter the relevant customer code for the customer you want to install.
Partners and Super-users
The Customer ID defaults to the customer code defined within your InfoZone profile, and must match the SYSPRO account you are installing.
The Customer PIN is the 6-digit code included in the email you received that contained your SYSPRO 8 license.
You can verify your customer ID and PIN against the CustomerId and CustomerPin elements of the license XML file.
 5. Installed Hotfixes
5. Installed Hotfixes
                                                                                        The Installed Hotfixes screen displays a list of all hotfixes installed for the deployment group. Alternatively use the Search box to search for a specific hotfix.
To find out more information about each hotfix that is installed, read the synopsis or select the More button to view additional information.
Identify which hotfix you want to uninstall and select the checkbox next to that hotfix.
Once you have indicated the hotfixes that you want to uninstall, select the Continue button.
You cannot uninstall a Mandatory Hotfix.












